Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000096 [LCD Display] Adjustments feature N/A 26-06-09 17:51 04-09-09 11:23
Reporter Peter View Status public  
Assigned To Peter
Priority high Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.02 Product Version 2.01
  Product Build
Summary 0000096: adjustments of fuel/ignition
Description consult active tests allow adjustments of fuel and ignition timing (across the rev range). possibly we can either have this activated when chosen just on the adjustment screen, or to also activate it whenever the display is on main display - effectively allowing u to change ignition timing without adjusting distributor etc.

however, not 100% as to how effective this is (e.g. will fuel adjustment be 'learned around' for cruise and/or load conditions), whether it works under all circumstances or is only in affect for some of the time. perhaps until this is determined should only work whilst on the screen?
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0000079)
BensDR30
28-06-09 18:28

If you were able to have the system apply tuning parameters to the ECU on power up, then you have effectively made a tunable ECU. This could be a little out of the realm of the display unit to manage, but storage / application of maps via the SD would be a BIG feature.
 
(0000082)
Peter
28-06-09 18:42

the main limitation to this would be the time it takes to 'switch' between different adjustments. so a single adjustment across the board would be fine, but as you increase the frequency of these boundary changes (which may take at least 10ms to maybe 100ms to switch between). but its definitely a possibility, even if its just a small amount of regions. the onboard eeprom could probably store the adjustment points (sdcard wouldnt be fast or reliable enough to), so there would be another limitation against doing too many adjustment points if it cannot all be stored in eeprom.
 
(0000086)
Peter
04-09-09 11:23

this is just for allowing adjustment while on adjustments screen - in future firmware the adjustments may be applied whilst on the main display, once theres a bit more evidence that the adjustments work as intended etc (just to make sure i havent made any mistakes or whatever). theres also a limit of +/-20% fuel (and 10 or 20 ignition timing, forget) in this firmware (this can be increased in future)
 

- Issue History
Date Modified Username Field Change
26-06-09 17:51 Peter New Issue
26-06-09 17:51 Peter Status new => assigned
26-06-09 17:51 Peter Assigned To  => Peter
28-06-09 18:28 BensDR30 Note Added: 0000079
28-06-09 18:42 Peter Note Added: 0000082
04-09-09 11:23 Peter Note Added: 0000086
04-09-09 11:23 Peter Status assigned => closed
04-09-09 11:23 Peter Resolution open => fixed
04-09-09 11:23 Peter Fixed in Version  => 2.02


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
45 total queries executed.
35 unique queries executed.
Powered by Mantis Bugtracker