Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000055 [Software] Sensors major have not tried 19-09-07 18:47 11-05-08 22:49
Reporter Peter View Status public  
Assigned To Peter
Priority high Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.3.3 Product Version 1.3.3
  Product Build beta4
Summary 0000055: fuel usage (and maybe others) dont take into account hibernate/car off times for fuel usage calcs
Description seems there is no check in the fuel usage calc to take into account when car isnt running/turned off. so when u start car again, the next fuel usage calc uses the total time elapsed since car was off and the gauge will spike up to a high value and stay there (as if car was "running" the whole time it was off).

from a user:
Basically I have a laptop running in the car and when the engine is turned off it switches to laptop battery and then hibernates in 5 minutes.
When the car is restarted , I have to push a button on the console to wake the computer.

What has been happening is that after I stop the car and leave it, say, arrive at work and come back in the arvo to drive home, all indicators work fine but the fuel used indicates 60L where as when I shut off the car in the morning it indicated 2L.
It seems something is still causing the software to count fuel used?
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0000044)
Peter
11-05-08 22:49

fixed in v1.3.3 final. if sensor has been more than 5s since last read (same timeout used for reconnect) then it won't add to trip meter sensors.
 

- Issue History
Date Modified Username Field Change
19-09-07 18:47 Peter New Issue
19-09-07 18:47 Peter Status new => assigned
19-09-07 18:47 Peter Assigned To  => Peter
11-05-08 22:49 Peter Note Added: 0000044
11-05-08 22:49 Peter Status assigned => closed
11-05-08 22:49 Peter Resolution open => fixed
11-05-08 22:49 Peter Fixed in Version  => 1.3.3


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker