Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000005 [Software] Sensors feature N/A 11-07-07 10:34 10-08-07 21:51
Reporter Peter View Status public  
Assigned To Peter
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.3.3 Product Version 1.3.2
  Product Build
Summary 0000005: Other Trip Meter Sensors (Fuel Used, Trip Fuel Economy, Trip Distance)
Description Fuel Used can be worked out from intermediate step in existing economy calculation, determining how long since last reading and infering how much fuel was used at that current rate, then added to previous value.

Trip Distance can be worked out in similar manner with speed (as it is in the LCD Display)

Trip Fuel Economy can then be worked out based on Fuel Used/Trip Distance
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0000005)
Peter
07-08-07 23:08

just realised i wont be able to test this release on my car as its out of action - might post a beta of it so other people can test it and see it works ok.

all these economy sensors will retain value for current ecutalk program session - ie u need to restart to clear values (maybe add a option to clear them later)
 
(0000007)
Peter
08-08-07 00:15

implemented pending testing it works properly. these 3 sensors max out all available room for cars that support all sensors (eg 300zx/gtr might), but i think thats ok since there wont be any new sensors for a while (until switches/registers are supported)
 
(0000009)
Peter
10-08-07 21:51

initial v1.3.3 beta release had two major issues when used on a pocket pc (laptop was fine), the first was the name of the sensors was not shown for distance/fuel used, the second was that ecutalk would exit if you choose either of these and displayed the gauges. both issues were caused by lack of support for the inline ternary operator:
(condition ? truevalue : falsevalue)

eg for setting distance sensor name:
(Settings.Imperial ? "Mi" : "KM")

the latest v1.3.3 beta 2 posted on news page has these issues fixed
 

- Issue History
Date Modified Username Field Change
11-07-07 10:34 Peter New Issue
11-07-07 10:35 Peter Category Gauges => Sensors
12-07-07 12:55 Peter Severity minor => feature
13-07-07 22:44 Peter Reproducibility always => N/A
05-08-07 01:01 Peter Status new => assigned
05-08-07 01:01 Peter Assigned To  => Peter
07-08-07 23:08 Peter Note Added: 0000005
08-08-07 00:15 Peter Note Added: 0000007
08-08-07 00:15 Peter Status assigned => closed
08-08-07 00:15 Peter Resolution open => fixed
08-08-07 00:15 Peter Fixed in Version  => 1.3.3
10-08-07 21:51 Peter Note Added: 0000009


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
47 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker