Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000037 [Software] Options minor have not tried 14-08-07 13:38 16-08-07 22:55
Reporter Peter View Status public  
Assigned To Peter
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.3.3 Product Version 1.3.3
  Product Build
Summary 0000037: Option dropdown lists are editable on laptop/PC (shouldn't be)
Description As the .NET Compact Framework dropdown combobox class doesnt have an option for the type of drop down list (eg whether you can type into the list), the default one is a non-editable list. however the default one on the .NET Framework (for laptop/pc) is an editable dropdown. Since it cant be changed as there is no option for .NET CF, something has to be done to make sure its not editable on normal .NET Framework. I think checking platform then using reflection to change dropdown style to list would probably work.
Steps To Reproduce
Additional Information If a user was to type invalid values into the dropdown id imagine there would be crashes, so fixing it is just a precaution.
Attached Files

- Relationships

- Notes
(0000013)
Peter
16-08-07 22:55

this is fixed in beta4 (when released) and after. now all dropdowns should not be editable.
 

- Issue History
Date Modified Username Field Change
14-08-07 13:38 Peter New Issue
14-08-07 13:38 Peter Status new => assigned
14-08-07 13:38 Peter Assigned To  => Peter
16-08-07 22:55 Peter Note Added: 0000013
16-08-07 22:55 Peter Status assigned => closed
16-08-07 22:55 Peter Resolution open => fixed
16-08-07 22:55 Peter Fixed in Version  => 1.3.3


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker