Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000124 [LCD Display] Connecting minor sometimes 15-01-11 12:58 16-08-16 11:49
Reporter Peter View Status public  
Assigned To Peter
Priority normal Resolution open Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 2.08 Product Version 2.04
  Product Build
Summary 0000124: Some Patrol ZD30 (mainly GU3?) have issues with slow connecting/dropping out.
Description Some patrol ZD30 owners (maybe 15% so far?), all GU III so far, have had issues with the display dropping out or being very slow to connect - from investigation thus far its most likely a bug in the ECU in the car, but the more info I can get the better. So I'll start listing any car info here for those cars which have had the problem.

White 2003 3ltr ST Auto, with NADS (Nissan Anti Detonation System) and some goodies (paul.helm on patrol4x4) - looks like this is GU III ST Wagon

02 GU ST Diesel/LPG (dronus4x4 on patrol4x4) - looks like this is GU III ST Wagon

2004 3 litre Patrol (David C) - looks like this is either GU III or GU IV, waiting on clarification

Nissan patrol GU III 3l ST Plus limited edition wagon (late 2002 build). NADS (Nissan anti detonation system) mods were done prior to ECUtalk, so I have no data beforehand (terra on patrol4x4)
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0000131)
Peter
16-08-16 11:47

So this is mostly fixed in v2.08 with some improvements to how the displays handle these ZD30's not communicating randomly, that it will often finally connect without user interaction... eventually :) (but much better than in the past).

connecting should be much more predictable and consistent now and automatically retry for some period rather than locking up the display. Also allows menu buttons to be pressed to bypass connection (which on some vehicles you couldnt even get into the menus to do this).
 
(0000132)
Peter
16-08-16 11:49

change notes:

1. minor changes to visual connection indication etc on startup (showing firmware version etc)
2. will connect at your selected speed from options (9404/9600/9804) 3 attempts first, then 1 of both other alternatives. so if you select 9404 it will do 9404,9404,9404,9600,9804 and repeat until it connects. Mostly leaving at 9600 is best.
3. will attempt connecting for 60s then go to main menu. also pressing the menu/enter button will skip it to main menu if its not able to connect (without waiting 60s).
4. few changes to a couple timings/delays/etc to hope to make it a bit better...
 

- Issue History
Date Modified Username Field Change
15-01-11 12:58 Peter New Issue
15-01-11 12:58 Peter Status new => assigned
15-01-11 12:58 Peter Assigned To  => Peter
15-01-11 13:15 Peter Summary Some Patrol ZD30 have issues with slow connecting/dropping out. => Some Patrol ZD30 (GU3?) have issues with slow connecting/dropping out.
15-01-11 13:15 Peter Description Updated
15-01-11 14:33 Peter Summary Some Patrol ZD30 (GU3?) have issues with slow connecting/dropping out. => Some Patrol ZD30 (GU3) have issues with slow connecting/dropping out.
15-01-11 14:33 Peter Description Updated
30-01-11 13:06 Peter Summary Some Patrol ZD30 (GU3) have issues with slow connecting/dropping out. => Some Patrol ZD30 (mainly GU3?) have issues with slow connecting/dropping out.
02-03-11 16:19 Peter Description Updated
16-08-16 11:47 Peter Note Added: 0000131
16-08-16 11:47 Peter Status assigned => closed
16-08-16 11:47 Peter Fixed in Version  => 2.08
16-08-16 11:49 Peter Note Added: 0000132


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker