Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000001 [Software] Connection feature N/A 11-07-07 10:13 05-08-07 00:29
Reporter Peter View Status public  
Assigned To Peter
Priority immediate Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 1.3.3 Product Version 1.3.2
  Product Build
Summary 0000001: Automatically attempt reconnection to ECU after connection lost
Description Particularly important for Pocket PC users, when you turn the car off, then back on again, you need to click on the gauges to exit out of them, then re-select the COMx port dropdown list to re-initiate the connection to the ECU. This is the case even if auto connect option is selected (which only auto connects on program start, not on disconnection).

Need to have it so ECUTalk will automatically retry connection whenever it is lost.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0000002)
Peter
05-08-07 00:29

when 5 seconds elapses since last data was received, ecutalk will start attempting to reconnect (whilst the gauges are still shown, ie in the background). so as soon as the connection is set back up (ie car started, consult cable plugged back in, etc), the gauges will start responding.

so, if you set up your pda so that it turns off after 30s when on battery power, then when your car turns off, the connection is lost, ecutalk will start to retry connection...then pda will be turned off, until you start car again, once pda turns back on it will reconnect and continue showing gauges/logging.
 

- Issue History
Date Modified Username Field Change
11-07-07 10:13 Peter New Issue
12-07-07 12:56 Peter Severity major => feature
13-07-07 22:45 Peter Reproducibility always => N/A
19-07-07 22:14 Peter Status new => assigned
19-07-07 22:14 Peter Assigned To  => Peter
05-08-07 00:29 Peter Note Added: 0000002
05-08-07 00:29 Peter Status assigned => closed
05-08-07 00:29 Peter Resolution open => fixed
05-08-07 00:29 Peter Fixed in Version  => 1.3.3


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
38 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker